Salesforce Service Disruption

Incident Report for Propel

Resolved

This incident has been resolved by the Salesforce Technology Team as of 11:38 pm UTC, Oct 20. For more information, please visit Salesforce's Trust Center: https://status.salesforce.com/generalmessages/20000226
Posted Oct 21, 2025 - 08:13 PDT

Identified

On October 20, 2025 at approximately 06:50 UTC, the Salesforce Technology team identified a service disruption impacting multiple clouds which affects Salesforce service for Propel customers. This is a system wide AWS outage. Salesforce services, including Heroku, are impacted.

For more information, please visit Salesforce's Trust Center: https://status.salesforce.com/incidents/20003370
Posted Oct 20, 2025 - 09:53 PDT
This incident affected: Propel Core Functionality, Propel Import, Propel Export, and PDF Generation Service.